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Preface

1. General information

1.1. Purpose
This Installation Guide explains how to install configure and upgrade the Talend modules and related
applications. For detailed explanation on how to use and fine-tune the Talend applications, please refer
to the appropriate Administrator or User Guides of the Talend solutions.

Information presented in this document applies to Talend products 6.0.1.

1.2. Audience
This guide is for administrators and users of the Talend products.

The layout of GUI screens provided in this document may vary slightly from your actual GUI.

1.3. Typographical conventions
This guide uses the following typographical conventions:

• text in bold: window and dialog box buttons and fields, keyboard keys, menus, and menu and
options,

• text in [bold]: window, wizard, and dialog box titles,

• text in courier: system parameters typed in by the user,

• text in italics: file, schema, column, row, and variable names,

• text in italics: file, schema, column, row, and variable names,

•
The  icon indicates an item that provides additional information about an important point. It is
also used to add comments related to a table or a figure,

•
The  icon indicates a message that gives information about the execution requirements or
recommendation type. It is also used to refer to situations or information the end-user needs to be
aware of or pay special attention to.

• Any command is highlighted with a grey background or code typeface.

2. Feedback and Support
Your feedback is valuable. Do not hesitate to give your input, make suggestions or requests regarding
this documentation or product and find support from the Talend team, on Talend's Forum website at:
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http://talendforge.org/forum

http://talendforge.org/forum
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Chapter 1. Prior to installing the Talend
products
This chapter provides useful information on software and hardware prerequisites you should be aware of, prior
to starting the installation of the Talend modules.

In the following documentation:

• recommended: designates an environment recommended by Talend based on our experiences and customer usage;

• supported: designates a supported environment for use with the listed component or service;

• supported with limitations: designates an environment that is supported by Talend but with certain conditions explained
in notes.
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1.1. Installation requirements
To make the most out of the Talend products, please consider the following hardware and software requirements.

Memory usage heavily depends on the size and nature of your Talend projects. However, in summary, if your Jobs
include many transformation components, you should consider upgrading the total amount of memory allocated
to your servers, based on the following recommendations.

Table 1.1. Memory usage

Product Client/Server Recommended alloc. memory

Studio Client 3GB minimum, 4 GB recommended

The same requirements also apply for disk usage. It also depends on your projects but can be summarized as:

Table 1.2. Disk usage

Product Client/Server Required disk space
for installation

Required disk space for use

Studio Client 3GB 3+ GB

Ulimit settings on Unix systems

• To make the most out of the Talend server modules and improve performance on Unix systems, you should
set the limit of system resources (ulimit) to unlimited.

Environment variable configuration: on Windows

Prior to installing your Talend solutions, you have to set the JAVA_HOME Environment variable:

• Define your JAVA_HOME and JDK_HOME environment variables so that they point to the JDK directory.

Example: if the JDK path is C:\Java\JDKx.x.x\bin, you must set the JAVA_HOME and JDK_HOME environment
variables to point to: C:\Java\JDKx.x.x.

It is highly recommended that the full path to the server installation directory is as short as possible and does not
contain any space character. If you already have a suitable JDK installed in a path with a space, you simply need to
put quotes around the path when setting the values for the environment variable.

Environment variable configuration: on Linux

Prior to installing your Talend solutions, you have to set the JAVA_HOME, JDK_HOME and Path environment
variables:

1. Find the JDK home dir and export it in the JAVA_HOME and JDK_HOME environment variables.

Example:

export JAVA_HOME=/usr/lib/jvm/jdk1.7.0_40
export JDK_HOME=/usr/lib/jvm/jdk1.7.0_40
export PATH=$JAVA_HOME/bin:$PATH
export PATH=$JDK_HOME/bin:$PATH

2. Add these four lines at the end of the global profiles in the /etc/profile file or in the user profiles in the
~/.profile file.

Note that after changing one of these files you have to log on again.

For more information on how to set the JAVA_HOME and JDK_HOME variables on Unix and Windows systems, see
the online Oracle documentation.

http://docs.oracle.com/cd/E19182-01/820-7851/inst_cli_jdk_javahome_t/index.html
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1.2. Studio specific prerequisites
To use the Studio properly, you first need to install external programs specific to bulk components (if you want
to use Oracle, Sybase, Informix or Ingres bulk functionality).

1.2.1.  Installing database client software (for bulk
mode)

Some bulk components, like Oracle, Sybase, Informix or Ingres, require database client software to run properly:

• OracleBulkExec uses the sqlldr external utility. This utility is available in Oracle clients that must be installed
on the computer.

• Informix uses the dbload external utility.

• Ingres uses the sql external utility.

• Sybase uses the bcp.exe external utility. This utility is asked for in the Sybase bulk components' Basic Settings
view. For more information, see tSybaseBulkExec, tSybaseOutputBulk and tSybaseOutputBulkExec components
on the appropriate Talend Components Reference Guide.

1.2.2. Installing the XULRunner package (for Linux
users)

On Linux, the XULRunner package is required to run the Studio.

The XULRunner package version that is recommended is XULRunner v1.9.2.28.

The XULRunner packages versions that are supported are v1.8.x - 1.9.x and v3.6.x.

1. Download XULRunner version from this location.

2. Unpack the archive file in the same directory where you unpacked the studio archive, but do not unpack it
within the Studio folder.

3. Add the following line at the end of the Studio .ini file that corresponds to your Linux architecture:

-Dorg.eclipse.swt.browser.XULRunnerPath=</usr/lib/xulrunner>

where </usr/lib/xulrunner> is the xulrunner installation path.

For example, if you have unpacked the Studio in a directory under your user home directory /home/<user>/
Talend/, you need to add the following to the .ini file:

-Dorg.eclipse.swt.browser.XULRunnerPath=/home/<user>/Talend/xulrunner/

1.3. Compatible Platforms and Java
environments
Please refer to the following grids for a summary of supported OS and Java Runtime environments.

http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2012/03/2012-03-02-03-32-11-mozilla-1.9.2/
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Table 1.3. Java environments

Support type Vendor Version

Recommended Oracle Java/JDK 8

For more information on Java specificities (version, OS compatibility), please see the Knowledge Base articles
on Talend Help Center.

Table 1.4. Talend Studio

Support type OS Version Processor

Unix Linux Ubuntu 12.04 64-bitRecommended

Windows Microsoft Windows Professional 7 64-bit

Linux Ubuntu 14.04 64-bit

Redhat Linux Enterprise Server Edition/
CentOS

7.1 64-bit

Redhat Linux Enterprise Server Edition/
CentOS

>= 6.1 64-bit

Unix

SUSE SLES 11 64-bit

Microsoft Windows 10 64-bit

Microsoft Windows 8.1 64-bit

Windows

Microsoft Windows 8 64-bit

OS X Yosemite/10.10 64-bit

OS X Mavericks/10.9 64-bit

Supported

Mac OS

OS X Mountain
Lion/10.8

64-bit

Deprecated Mac OS OS X Lion/10.7 64-bit

https://help.talend.com/
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Chapter 2. Installing Talend Studio for the
first time
We strongly encourage you to read the Prior to installing the Talend products before starting this chapter.

This chapter details the procedures required to install Talend Studio.
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2.1. Downloading and installing Talend
Studio
Download

1. Get the archive file from the download section of the Talend website.

Note that the .zip file contains binaries for ALL platforms (Linux/Unix, Windows and MacOS).

2. Once the download is complete, extract the archive file on your hard drive.

It is recommended to avoid spaces and long names in the target installation directory path.

Configure the memory settings

• If you want to tune the memory allocation for your JVM, you only need to edit the .ini file corresponding
to your executable file. For example:

• For Talend Studio on 32bit-Windows, edit the file: TOS_DI-win32-x86.ini;

• For Talend Studio on Linux, edit the file: TOS_DI-linux-gtk-x86.ini.

The default values are:

-vmargs -Xms40m -Xmx500m -XX:MaxPermSize=128m

If you only have 512MB of memory on your computer, you can specify the memory allocation as following,
for example:

-vmargs -Xms40m -Xmx256m -XX:MaxPermSize=64m

Learn more on http://www.oracle.com/technetwork/java/hotspotfaq-138619.html

2.2. Launching Talend Studio
The following procedures describe how to launch the Studio, how to log in the Studio and how to create your
first project.

2.2.1. Launching the Studio

Launch the Studio

• On Windows, double-click the executable file to launch Talend Studio.

On Unix-like systems, add execution rights on the desired TOS_DI-* binary before launching it.

On a standard Linux box, the command is:

$ chmod +x TOS_DI-linux-gtk-x86.sh
$ ./TOS_DI-linux-gtk-x86.sh

On Mac OS X, launch the following file:

TOS_DI-macosx-cocoa.app/Contents/MacOS/TOS_DI-macosx-cocoa

http://www.talend.com/download
http://www.oracle.com/technetwork/java/hotspotfaq-138619.html
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Public license

• First screen is a license screen. In the [License] window that appears, read and accept the terms of the license
agreement to proceed to the next step.

Login and first project

1. As first time user, you need to set up a new project or you can also import a Demo project which gathers
numerous job samples.

2. To import a demo project, select Import a demo project and click Finish. In the dialog box that opens,
select the project you want to import.

To create a new project, select Create a new project and enter the name of your project in the corresponding
field.

3. Click Finish when complete, to open a welcome window and launch the Studio.

2.3. Configuring Talend Studio
Talend Studio requires specific third-party Java libraries or database drivers (.jar files) to be installed to connect
to sources and targets. Those libraries or drivers, known as external modules, can be required by some of Talend
components or by some connection wizards or by both. Due to license restrictions, Talend may not be able to ship
certain external modules within Talend Studio.

2.3.1. Identify required external modules

When you launch Talend Studio or select Help > Install Additional Packages in the Talend Studio menu, if any
external modules are found missing for any features, the [Additional Talend packages] wizard opens, showing
the Optional and Required third-party libraries check boxes. Make sure these check boxes are selected and
click Finish to open the [Download external modules] dialog box, which lists all the available external modules,
displays the license terms under which the external modules are provided, and lets you install all the modules at
a single click. For more information, see Install external modules.

On your design workspace, if a component requires the installation of external modules before it can work properly,
a red error indicator appears on the component. With your mouse pointer over the error indicator, you can see a
tooltip message showing which external modules are required for that component to work.
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When you open the Basic settings or Advanced settings view of a component for which one or more external
modules are required, you will see a piece of highlighted information about external modules, followed by an
Install button. Clicking the Install button opens a wizard that will show you the external modules to be installed.

The Modules view lists all the modules required to use the components embedded in the Studio, including those
Java libraries and drivers that you must install to get the relevant components or Metadata connection working.

If the Modules view is not shown under your design workspace, go to Window > Show View… > Talend and
then select Modules from the list.

The table below describes the information presented in the Modules view.

Column Description

Status points out if a module is installed or not installed on your system.

The  icon indicates that the module is not necessarily required for the corresponding component
or Metadata connection listed in the Context column.

The  icon indicates that the module is absolutely required for the corresponding componentor
Metadata connection.

Context lists the name of Talend componentor Metadata connection using the module. If this column is
empty, the module is then required for the general use of Talend Studio.

This column lists any external libraries added to the routines you create and save in the
Studio library folder. For more information, see the Talend Studio User Guide.

Module lists the module exact name.

Description explains why the module/library is required.

Required the selected check box indicates that the module is required.

In addition to the Modules view, the Studio provides a mechanism that enables you to easily identify, download
and install most of the required third-party modules from the Talend website and directs you to valid websites
for the rest.

A Jar installation wizard appears whenever any required external module is found missing for any feature in the
Studio, including when you:

• drop a component from the Palette if one or more external modules required for that component to work are
missing in the Studio, or

• click the Check button in a Metadata connection setup wizard in Talend Studio if one or more external modules
required for the connection are missing in the Studio, or

• click the Guess schema button in the Component view of a component if one or more external modules required
for that component to work are missing in the Studio,
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• click Install on the top of the Basic settings or Advanced settings view of a component for which one or more
required external modules are missing,

• run a Job that involves components or Metadata connections for which one or more required external modules
are missing, or

• click the  button in the Modules view.

When you click this button, the wizard that appears will list all the required external modules that are not integrated in
the Studio.

The table below describes the information presented in the wizard.

Item Description

Jar The file name of the external module.

Module A short description about the nature of the module.

Required by component Lists the components that require the external module.

Required The selected check box indicates that the module is required.

License The license under which the module is provided.

More information Provides the URL of the valid website where you can find more information about this module
and download the module manually.

Action : Click to open the [Download external modules] dialog box to download
and install the module, which is available on the Talend website;

: Click the link to open the valid website to download the module, which
is not available on the Talend website, and then click the jar button to import the downloaded
module into your studio;

: You need to find and download the module yourself and click the jar
button to import it into the your studio.

Click to open the [Download external modules] dialog box to download and install all the
required modules that are available on the Talend website.

Do not show again
Select to prevent the wizard from appearing again unless you click the  button in the
Modules tab view.

This check box shows only when you drop a component, set up a connection, or guess the
schema of a database, that requires an external module, or click the Install button on the
Component tab of a component that requires an external module.

Click here to obtain more
information about external
modules

Click to go to Talend online documentation on installing third-party modules.
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This wizard lists the external modules to be installed, the licenses under which they are provided, and the URLs
of the valid websites where they are downloadable, and allows you to download and install automatically all the
modules available on the Talend website and download those not available on the Talend website by following
the links provided in the Action column and then install them into your Studio manually.

When you drop a component, set up a connection, or guess the schema of a database, that requires an external
module for which neither the Jar file nor its download URL information is available on the Talend website, the
Jar installation wizard does not appear, but the Error Log view will present an error message informing you that
the download URL for that module is not available. You can try to find and download it by yourself, and then
install it manually into the Studio.

To show the Error Log view on the tab system, go to Window > Show views, then expand the General node and select
Error Log.

2.3.2. Install external modules

To download and install modules in the Studio

To download and install external modules automatically, do the following:

If you are working behind a network proxy, make sure you have correctly set up your proxy before you can download and
install external modules in your Studio. To access the proxy settings, select Window > Preferences from the menu to open
the [Preferences] window, then expand the General node and click Network Connections.

1. In the Jar installation wizard, click the Download and Install button to install a particular module, or click
the Download and install all modules available button to install all the available modules, or select Help >
Install Additional Packages from the menu to open the [Additional Talend Packages] wizard. From this
wizard, make sure the Optional and Required third-party libraries check boxes are selected and click Finish.
The [Download external modules] dialog box opens.

This [Additional Talend Packages] wizard appears automatically when you launch Talend Studio if any additional
packages, including external modules, need to be installed for any features to function in the Studio.
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2. To download and install the external module(s) provided under a particular license, select that license from
the Licenses pane, review the license terms, select the I accept the terms of the license agreement option,
and click Finish to start the download and installation process.

To download and install all external modules provided under all the listed licenses, click the Accept all button
to start the download and installation process.

Upon installation of the chosen external module or modules, a dialog box appears to notify you about the
number of modules successfully installed and/or about the modules failed to install, if any.

To install manually an external module you already have in your local file system, do the following:

1. Click the  button in the upper right corner of the Modules view or in Jar installation wizard to browse
your local file system.

If the Modules view is not shown under your design workspace, go to Window > Show View… >
Talend and then select Modules from the list.

2. In the [Open] dialog box of your file system, browse to the module you want to install, double-click
the .jar file, or select it and then click Open to install it.

The dialog box closes and the selected module is installed in the library folder of the current Studio.

You can now use the component or Metadata connection dependent on this module in any of your Job
designs.

To install modules downloaded from external websites

Some modules are not available on the Talend website but can be downloaded directly from external websites.
Once downloaded, these modules must be placed in specific folders.
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• For the studio, the downloaded modules must be placed in the following folder:

<StudioPath>/lib/java
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Chapter 3. Upgrading your Talend products
This chapter describes the various operations required to migrate version of the Talend solutions.

We assume that you have installed and configured these solutions as described in the Installing Talend Studio
for the first time.

The migration and upgrade process includes the following mandatory steps:

These steps usually need to be completed in the following order.

1. Backing up the environment, see the Backing up the environment.

2. Upgrading the Talend projects in the Studio, see the Upgrading the Talend projects in the Studio.
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3.1. Backing up the environment
Before you start migrating your Talend solutions, make sure your environment is correctly backed up.

The environment backup process includes the following mandatory steps:

These steps usually need to be completed in the following order.

1. Saving the local projects, see Saving the local projects.

Saving the local projects

1. Launch the Studio.

2.
Click the  icon and export your local projects to an archive file.

3.2. Upgrading the Talend projects in the
Studio

Importing your local projects

1. Launch the new Studio you have just installed.

2. In the login window, select Import, then import the archive file containing your local projects.

The local projects are displayed in the Project list and appear on the Studio Repository view.

For more information on how to export local projects to an archive file, see Saving the local projects.
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Appendix A. Supported Third-Party System/
Database/Business Application Versions
This document provides the information about the versions of the systems or databases or business applications
supported by Talend Studio.
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A.1. Supported systems, databases and
business applications by Talend components
The access to these systems, databases and business applications varies depending on the Studio you are using.

Systems/Databases Versions OS Available with...

Alfresco 2.1 N/A1 All Talend products

Amazon Redshift Initial release of Amazon
Redshift

N/A1 All Talend products

AS/400 V5R2 to V5R4

V5R3 to V6R1

V6R1 to V7R2

N/A1 All Talend products

Access2 2003/2007 Windows Talend products with Data Integration
(DI), Master Data Management (MDM),
Enterprise Service Bus (ESB) or Big Data

Bonita 5.2.3/5.3.1/5.6.1/5.10.1/6.5.2N/A1 All Talend products

Cassandra 2.0.0

(Deprecated versions:
1.1.2/1.2.2)

Windows + Linux Talend products with Big Data

CouchBase 2.0 Windows Talend products with Big Data

CouchDB 1.0.2 Windows Talend products with Big Data

DB Generic ODBC Windows All Talend products

DB2 10.5

10.1

Windows + Linux Talend components with all products.

Talend products with MDM or ESB.

EXASolution 4 Windows Talend products with DI, MDM, ESB or Big
Data

FireBird 2.1 Windows + Linux Talend products with DI, MDM, ESB or Big
Data

Greenplum 4.2.1.0 Windows (client only) +
Linux

Talend products with DI, MDM, ESB or Big
Data

HSQLDb 1.8.0 N/A1 Talend products with DI, MDM, ESB or Big
Data

Informix 11.50 Windows + Linux All Talend products

Ingres 9.2 Windows + Linux All Talend products

Interbase 7 and above N/A1 Talend products with DI, MDM, ESB or Big
Data

JavaDB 6 Windows + Linux Talend products with DI, MDM, ESB or Big
Data

LDAP No version limitation Windows + Linux All Talend products

Microsoft AX Dynamics AX 4.0

Dynamics AX 2012

N/A1 All Talend products

Microsoft CRM 2011/2015 N/A1 All Talend products

MS SQL Server 2000/2003/2005/2008/2012Windows + Linux All Talend products

MaxDB 7.6 N/A1 Talend products with DI, MDM, ESB or Big
Data

MongoDB 2.5.X/2.6.X/3.0.X Windows + Linux Talend products with Big Data

MySQL Mysql4

Mysql5

Windows + Linux All Talend products
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Systems/Databases Versions OS Available with...

Netezza 7.2 Windows + Linux All Talend products

Neo4j 1.X.X/2.X.X Linux Talend products with Big Data

OleDb 2000/2003/2005/2007/2010N/A1 All Talend products

Oracle Oracle 8i/9i/10g/11g/11g
(11.6)/12c

Windows + Linux All Talend products

ParAccel 3.1/3.5 N/A1 Talend products with DI, MDM, ESB or Big
Data

PostgreSQL Prior to v9/v9.X Windows + Linux All Talend products

PostgresPlus Prior to v9/v9.X Windows + Linux Talend products with DI, MDM, ESB or Big
Data

Salesforce until V26 Windows + Linux All Talend products

SAP 4.6 Windows All Talend products

SAP Hana 1.0 Windows All Talend products

SQLite 3.6.7 Windows + Linux All Talend products

Sybase 12.5/12.7/15.2/15.5/15.7 Windows + Linux All Talend products

SybaseIQ 12.5/12.7/15.2 Windows + Linux All Talend products

Teradata 12/13/14/15 Windows + Linux All Talend products

VectorWise 2 Windows + Linux Talend products with DI, MDM, ESB or Big
Data

Vertica 3/3.5/4/4.1/5.0/5.1/6.0/6.1.X/7.0.XWindows + Linux Talend products with DI, MDM, ESB or Big
Data

VtigerCRM Vtiger 5.0

Vtiger 5.1

N/A1 All Talend products

1. The test information is not available yet.

2. When working with Java 8, only the General collation mode is supported.
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